Amiga Racer asks me the powersdl.library v15
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 193 from 2012/4/28
    I have this current problem with the game running on MorphOS, it asks me the powersdl.library v15 when I have installed the v16.1, it is one bug in the game and where I can find the v15?
    Amiga 500 with ROMs 1.3-2.05 and M-Tec AT 500 with hard disk and 4MB Ram.
    WinUAE + original OS 3.5&3.9
    Sam440ep 800 MHZ + OS 4.1 F.E.
    Sam460ex 1 GHz + OS 4.1 + Update 6. K.O.
    MacMini 1.5 GHz + MorphOS 3.9
    PowerBook G4 1.65 + MorphOS 3.9
  • »19.11.17 - 09:54
    Profile Visit Website
  • MorphOS Developer
    Henes
    Posts: 495 from 2003/6/14
    The message does not mean the game is asking for powersdl.library v15 specifically.
    It means it is asking for any version equal or superior to v15. So a v16 must work.

    There could be various reasons for your issue:

    1) You have several versions installed and something is opening the v15 first.
    You should make sure you have only one version in sys:libs/ and nowhere else (f.e. in some game's own libs/ directory).
    You can use Ambient's built-in search functionality to find all your powersdl.library copies...

    2) v16 requires some other library missing on your system. Snoopium (if correctly configured) will help you in this case.

    3) more...

    And the same for all powersdl's sub libraries (powersdl_image, powersdl_mixer etc...)
  • »19.11.17 - 11:15
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    igracki
    Posts: 263 from 2003/2/24
    From: Berlin
    I have v16.1 and AmigaRacer starts/run without a problem!

    These powersdl libraries are needed/opened by AmigaRacer:
    powersdl.library v16.1
    powersdl_mixer.library v8.9
    powersdl_net.library v8.2
    powersdl_ttf.library v8.1
  • »19.11.17 - 12:56
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    defender
    Posts: 211 from 2011/4/24
    After updating to 3.98 i got this message:
    Warning: Not enough free sectors (0) to place 50 objects.

    But only in swisserland!
    Everythings else (what I have tested now) works fine.
    PowerMac 3.6 - Radeon 9000_64Mb - 1,5Gb Ram - SB Live - MorphOS 3.9
    CD32 - PowerBook 1,67GHz 1GB/100GB - MorphOS 3 reg. 1455
  • »19.11.17 - 16:49
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 193 from 2012/4/28
    Thank you.
    I installed the Barkanoid demo and it installed several libraries, may7be the installer script corrupt some library, but I reinstalled the v16.1 even to copy them from my macmini.
    Amiga 500 with ROMs 1.3-2.05 and M-Tec AT 500 with hard disk and 4MB Ram.
    WinUAE + original OS 3.5&3.9
    Sam440ep 800 MHZ + OS 4.1 F.E.
    Sam460ex 1 GHz + OS 4.1 + Update 6. K.O.
    MacMini 1.5 GHz + MorphOS 3.9
    PowerBook G4 1.65 + MorphOS 3.9
  • »19.11.17 - 18:22
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 193 from 2012/4/28
    Quote:

    igracki escribió:
    I have v16.1 and AmigaRacer starts/run without a problem!

    These powersdl libraries are needed/opened by AmigaRacer:
    powersdl.library v16.1
    powersdl_mixer.library v8.9
    powersdl_net.library v8.2
    powersdl_ttf.library v8.1


    I have these library versions too. The problem has in other way.
    Amiga 500 with ROMs 1.3-2.05 and M-Tec AT 500 with hard disk and 4MB Ram.
    WinUAE + original OS 3.5&3.9
    Sam440ep 800 MHZ + OS 4.1 F.E.
    Sam460ex 1 GHz + OS 4.1 + Update 6. K.O.
    MacMini 1.5 GHz + MorphOS 3.9
    PowerBook G4 1.65 + MorphOS 3.9
  • »19.11.17 - 18:25
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    igracki
    Posts: 263 from 2003/2/24
    From: Berlin
    Here too!
    I tried the ARCS feature and selected Swisserland and pressed "Build Track" then the message appeared in a shell window:
    Warning: Not enough free sectors (0) to place 10 objects.
  • »19.11.17 - 18:53
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 193 from 2012/4/28
    Maybe the game needs a new update for the executable.
    Amiga 500 with ROMs 1.3-2.05 and M-Tec AT 500 with hard disk and 4MB Ram.
    WinUAE + original OS 3.5&3.9
    Sam440ep 800 MHZ + OS 4.1 F.E.
    Sam460ex 1 GHz + OS 4.1 + Update 6. K.O.
    MacMini 1.5 GHz + MorphOS 3.9
    PowerBook G4 1.65 + MorphOS 3.9
  • »20.11.17 - 10:22
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 193 from 2012/4/28
    Solved, I reinstalles MorphOS and now the game works, only for MorphOS v3.10 I hope that it will have a better core for PowerBook G4 because the current 3.9 gives much problems.
    Amiga 500 with ROMs 1.3-2.05 and M-Tec AT 500 with hard disk and 4MB Ram.
    WinUAE + original OS 3.5&3.9
    Sam440ep 800 MHZ + OS 4.1 F.E.
    Sam460ex 1 GHz + OS 4.1 + Update 6. K.O.
    MacMini 1.5 GHz + MorphOS 3.9
    PowerBook G4 1.65 + MorphOS 3.9
  • »03.12.17 - 13:14
    Profile Visit Website
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Stevo
    Posts: 789 from 2004/1/24
    From: #AmigaZeux
    Quote:

    Templario wrote:
    Solved, I reinstalles MorphOS and now the game works, only for MorphOS v3.10 I hope that it will have a better core for PowerBook G4 because the current 3.9 gives much problems.


    Funny, 3.9 works like a charm on my Powerbook, no issues whatshowever.
    ---
    http://www.iki.fi/sintonen/logs/its_only_football.txt
  • »03.12.17 - 20:11
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Templario
    Posts: 193 from 2012/4/28
    Quote:

    Stevo escribió:
    Quote:

    Templario wrote:
    Solved, I reinstalles MorphOS and now the game works, only for MorphOS v3.10 I hope that it will have a better core for PowerBook G4 because the current 3.9 gives much problems.


    Funny, 3.9 works like a charm on my Powerbook, no issues whatshowever.


    I have your good luck with my MacMini, because with my PowerBook sometime I have problems with the visual enviroment other times with OWB with it has enable the javascript and OWB crash because also crash the MorphOS.
    Amiga 500 with ROMs 1.3-2.05 and M-Tec AT 500 with hard disk and 4MB Ram.
    WinUAE + original OS 3.5&3.9
    Sam440ep 800 MHZ + OS 4.1 F.E.
    Sam460ex 1 GHz + OS 4.1 + Update 6. K.O.
    MacMini 1.5 GHz + MorphOS 3.9
    PowerBook G4 1.65 + MorphOS 3.9
  • »05.12.17 - 13:36
    Profile Visit Website