Terminal software + FTDI TTL-232R
  • Just looking around
    Symbola
    Posts: 11 from 2015/9/22
    From: Plymouth, UK
    I would like to connect my MorphOS computer to my Windows computer using two USB to serial cables.

    When I use two Windows computers I use Realterm, what would be a good alternative to use on MorphOS?

    Is the FTDI TTL-232R cable compatible with MorphOS?
  • »15.02.17 - 20:39
    Profile Visit Website
  • Order of the Butterfly
    Order of the Butterfly
    zukow
    Posts: 448 from 2005/2/9
    From: Poland
    I've started ftdi drivers some time ago but it isn't finished so no ftdi converter for now. PL2303 converters works. I used Term (from Aminet) for serial communictation.
  • »16.02.17 - 17:37
    Profile Visit Website
  • Just looking around
    Symbola
    Posts: 11 from 2015/9/22
    From: Plymouth, UK
    OK, thanks for the info zukow…

    I had a genuine FTDI cable, and a non-genuine FTDI cable that I thought was a Prolific cable…

    Now I have found a couple of genuine Prolific 2303 cables I have got it to work…

    Windows 10 64 bit:-

    To get the Prolific 2303 USB cable to work on Windows 10 I had to download an older version of the driver (V 3.3.2.102 [24/09/2008])

    Faulty (new drivers) have an exclamation mark next to the device in device manager!

    Here is a link on my website, if anyone needs it:-
    Profilic_Win8_x64_x86.zip

    To upgrade (well, downgrade) the driver…
    Plug in the Prolific cable…

    -> Device Manager
    -> Expand Ports (COM & LPT)
    -> Right click on the Prolific COM port (i.e. “Prolific USB-to-serial Comm Port (COMx)
    -> Update Driver Software…
    -> Browse my computer for driver software
    -> Let me pick from a list of device drivers on my computer
    -> Have Disk…
    -> Browse to the above extracted zip
    -> Select “ser2pl”
    -> OK
    -> Double click on the available driver
    -> Wait for driver to install -> close window.

    Exclamation mark should now be gone…

    I used Realterm, set the COM port to the Prolific cable and speed to 19200. (click on change and open port)

    Here is a link on my website, if anyone needs it:-
    Realterm_2.0.0.70_Signed_Wrapper_setup.exe

    MorphOS 3.9:-

    I used Term 4.8 from Aminet.

    Here is a link on my website, if anyone needs it:-
    Term.lha

    In Term change the settings…

    -> Settings
    -> Serial
    -> Device
    -> Set serial device to “serialpl2303.device”
    -> Use

    It's then possible to type in either terminal program and text will appear in the other terminal program.

    Looking in MorphOS prefs...

    -> USB
    -> Devices

    This will show if the Prolific driver is installed and working, and the correct bindings to use in Term…

    Hardware...

    -> Two Prolific 2303 cables
    -> Red wires not connected
    -> Black wires connected together (0V)
    -> Green and white wires swapped over (i.e. Rx to Tx, and Tx to Rx)

    Well, I hope that might help another user… :)


    [ Edited by Symbola 16.02.2017 - 19:33 ]
  • »16.02.17 - 19:32
    Profile Visit Website