SOLVED: PowerMac G5 will no longer boot MorphOS
  • Butterfly
    Butterfly
    danwood
    Posts: 95 from 2009/10/5
    Hey guys, my Powermac g5 will no longer boot MorphOS as of today!

    Booting from the hard disk just shows a grey screen and goes no further, trying to boot from 3.8 or 3.9 CD-ROM just shows white screen and goes no further.

    The system has been running MorphOS fine for months, and it will still boot into OS X fine.

    Any idea?

    I've tried disconnecting the morphos hard disk, but the CD-ROM will still only show a white screen now.

    EDIT: Never mind, seems my DH1: was badly corrupted (block errors all over!) think it's time for a new hard disk. Got it to boot from CD after NVRam reset and removing drive.

    [ Edited by danwood 28.07.2015 - 20:11 ]
  • »28.07.15 - 19:18
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    Yasu
    Posts: 1724 from 2012/3/22
    From: Stockholm, Sweden
    This is why I do plenty of backups :-)

    I've also had huge problems with my two G5:s. Both died on me. After having them checked, we first thought it was due to faulty RAM becise we could get them to boot again. But they broke down again. It turned out to be a common G5 problem: the computer runs so hot that various chip solderings weakens and fall off. Not break, but get loose. You can apparently fix it by reheating the soldrings with a really hot hair dryer. If you are lucky.
    AMIGA FORUM - Hela Sveriges Amigatidning!
    AMIGA FORUM - Sweden's Amiga Magazine!

    My MorphOS blog
  • »29.07.15 - 11:37
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    amigadave
    Posts: 2793 from 2006/3/21
    From: Northern Calif...
    I have not used MorphOS on my G5 PowerMac until just recently, as I was waiting for the support of R400 based video cards, which came some time ago, but I delayed installing to the G5 even longer due to moving to a different house and having most of my hobby computer gear packed up.

    With the event of last weekends Amiga30 computer show in Mountain View, California, I could delay no longer, as I needed the G5 system for the show, so I finally completed the installation of MorphOS3.9 on my G5 tower and used it to display during the show on the dedicated MorphOS table. The install took me several tries and a couple of days, but I was finally successful in getting it installed and working, but the system ability to boot into MorphOS3.9 is very unreliable. It seems to run fine once it boots up, and I have seen it run for many hours without any problems, but often it will refuse to fully boot up. It sometimes gets stuck on an all white screen, or the MorphOS3.9 splash screen, while other times it will get further and freeze on the Ambient screen before it has drawn any of the device icons. Would it be helpful to anyone if I attempted to diagnose the freezing up during the boot process by recording some debug output for others to look at? I don't know how to do that, as the results would be over my head, but I will find out how to get the debug output, if anyone wants it. I just figured since the point at where the system is freezing up during the boot process is different almost each time, the results may not be as helpful as they would be if it were freezing at the same exact point each time.

    Since I am using a PC video card which has been re-flashed with a Mac ROM to work in my G5, I won't complain, or assume that it is a problem with the OS, as re-flashed video cards are not officially supported by the MorphOS Dev. Team. Instead, I will look around for a genuine Mac video card that has the same or better performance as my FireGLX3 Radeon w/R420 GPU, and see if that solves my intermittent booting problems. If the intermittent booting problems still exist after switching to a genuine Mac video card, then I must have a corrupted installation, a hardware fault somewhere else in the computer, or there is some kind of bug in MorphOS3.9 that only shows up on G5 systems.
    MorphOS - The best Next Gen Amiga choice.
  • »30.07.15 - 17:19
    Profile