Cannot boot sam460cr
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    I cannot boot my sam460cr with a Radeon X1650 (non pro).
    I tried booting from CD and from SD card. The system begins booting, but stops after some seconds. THe last visible message is:
    Quote:


    Loaded bootsam_ppc4x0.img from ISO9660, booting...


    or:
    Quote:


    Loaded bootsam_ppc4x0.img from "SDH0:", booting...



    Edit:
    The only graphics card from which I boot Morphos is a 5450. The R7 250E (7750) and the X1650 wont boot with morphos.

    [ Editiert durch metatron 06.07.2015 - 18:56 ]
  • »06.07.15 - 19:46
    Profile
  • Jim
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Jim
    Posts: 4957 from 2009/1/28
    From: Delaware, USA
    The X1650 is not listed in the compatibility list, only the X1600 (Pro or non-Pro).
    Although you would assume that the X1650 ought to work, it obviously has not been tested.

    Does your SAM have the latest firmware?
    "Never attribute to malice what can more readily explained by incompetence"
  • »06.07.15 - 21:09
    Profile
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    Andreas Wolf posted that a X1650 is supported:
    https://morph.zone/modules/newbb_plus/viewtopic.php?forum=38&topic_id=9764&post_id=108728&viewmode=flat&sortorder=0&showonepost=1

    Board is new and fw is up to date.
    Edit:
    NO. Firmware is not the current one, its not the 2015a.


    [ Editiert durch metatron 06.07.2015 - 20:59 ]
  • »06.07.15 - 21:50
    Profile
  • Jim
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Jim
    Posts: 4957 from 2009/1/28
    From: Delaware, USA
    Quote:

    metatron wrote:
    Andreas Wolf posted that a X1650 is supported:
    https://morph.zone/modules/newbb_plus/viewtopic.php?forum=38&topic_id=9764&post_id=108728&viewmode=flat&sortorder=0&showonepost=1

    Board is new and fw is up to date.
    Edit:
    NO. Firmware is not the current one, its not the 2015a.


    [ Editiert durch metatron 06.07.2015 - 20:59 ]


    Yes, I would assume virtually any R500 gpu based board should work, but the X1650 is not listed at www.morphos-team.net/hardware.
    But I would update the SAM's firmware before considering that as a potential problem.
    "Never attribute to malice what can more readily explained by incompetence"
  • »06.07.15 - 22:20
    Profile
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    You are right. I purchased the new firmware last night and will update it soon.
  • »07.07.15 - 05:28
    Profile
  • MorphOS Developer
    bigfoot
    Posts: 381 from 2003/4/11
    What is the PCI device ID of your Radeon X1650?
    I rarely log in to MorphZone which means that I often miss private messages sent on here. If you wish to contact me, please email me at [username]@asgaard.morphos-team.net, where [username] is my username here on MorphZone.
  • »07.07.15 - 06:44
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > Andreas Wolf posted that a X1650 is supported

    Not quite. I posted that the graphics driver developer had said that the X1650 was supported :-)
  • »07.07.15 - 09:36
    Profile
  • Jim
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Jim
    Posts: 4957 from 2009/1/28
    From: Delaware, USA
    Quote:

    metatron wrote:
    You are right. I purchased the new firmware last night and will update it soon.


    Anyone else find it odd that the Amiga community has to buy firmware updates and video drivers? I guess it is just an indication of how small the market is.

    If this problem is related to an issue with the drivers, well they are new and the R500 series covers a broad range of cards.
    Since Bigfoot has already asked a specific question, I am sure he has a few ideas on how to sort it out.

    Thanks to our developers I have moved from R200, to R300, then R400, and soon R500.
    That is a lot of development for part time non paying work.

    And Radeon HD support is likely to improve over time. You just need to be patient. It can't be done in two weeks.
    "Never attribute to malice what can more readily explained by incompetence"
  • »07.07.15 - 15:14
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    takemehomegrandma
    Posts: 2708 from 2003/2/24
    Quote:

    Jim wrote:

    Anyone else find it odd that the Amiga community has to buy firmware updates and video drivers?


    I suppose you mean OS4-community?

    First pay €1000 a Sam system with OS4. Then pay extra for a firmware update. Then pay extra for 2D accelerated drivers for the GFX card that came with the system but is not supported by the OS. Then they decide to not release 3D for the cards sold with the systems, so you will have to pay extra for a HD7xxx GFX card. And then you will have to pay extra for a separate 3D driver for this card. Only to reach 31.0 FPS in Q3 @ 1280x1024. On a Radeon HD7xxx card!

    "Odd" is the understatement of the year!

    Quote:

    I guess it is just an indication of how small the market is.


    I think it has more to do with policy than market size. €9 from a few hundred users won't make much of a difference financially anyway. It's just strange. Or part of a long term effort to make OS4 users become accustomed to and feel "natural" about paying fees for everything, all the time (re-routing people to "app-stores" instead of Aminet or normal websites), even things that normally is included as part of product support, like updated firmware and drivers.
    MorphOS is Amiga done right! :-)
    MorphOS NG will be AROS done right! :-)
  • »07.07.15 - 17:45
    Profile
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    This is the output from the serial connector (115200 8n1):
    Quote:



    U-Boot 2015.a (May 16 2015 - 14:20:11)

    CPU: AMCC PowerPC 460EX Rev. B at 1100 MHz (PLB=220 OPB=110 EBC=110)
    No Security/Kasumi support
    Bootstrap Option H - Boot ROM Location I2C (Addr 0x52)
    Internal PCI arbiter enabled
    32 kB I-Cache 32 kB D-Cache
    Board: Sam460ex/cr, PCIe 4x + PCIe 1x
    I2C: ready
    DRAM: 2 GiB (ECC not enabled, 440 MHz, CL4)
    PCI: Bus Dev VenId DevId Class Int
    00 04 1095 3114 0106 00
    PCIE0: link is not up.
    PCIE1: successfully set as root-complex
    02 00 1002 71c7 0300 ff
    Net: ppc_4xx_eth0
    FPGA: Revision 03 (2010-10-07)
    SM502: not found
    PERMD2:not found
    VGA: 1
    VESA: OK

    Got past the basic MMU setup
    L2 cache enabled
    DCR 0x40: 0000e000
    DCR 0x41: 1000e000
    DCR 0x42: 00000000
    DCR 0x43: 00000000
    Calculated 0x80000000 bytes of RAM
    Board configured in PCI Express mode
    PIC initialised
    CPU Frequency: 1100.000MHz
    Filtered write of 0xffffffff to PCIX1 config space address 0x14
    Filtered read from PCIX1 config space address 0x14
    Filtered write of 0xffffffff to PCIX1 config space address 0x1c
    Filtered read from PCIX1 config space address 0x1c
    Filtered write of 0xffffffff to PCIX1 config space address 0x20
    Filtered read from PCIX1 config space address 0x20
    Filtered read from PCIX1 config space address 0x30
    Filtered write of 0xfffffffe to PCIX1 config space address 0x30
    Filtered read from PCIX1 config space address 0x30


    ABox 1.28 (02.05.2014) ▒ 1999-2014 by Ralph Schmidt, Emmanuel Lesueur, Teemu Sui kki, Harry Sintonen
    Driver_InitBoard: Channels = 4 UnitsPerChannel = 1
    PCI (S)ATA/ATAPI Driver@0: PIO Mode 4
    PCI (S)ATA/ATAPI Driver@0: UDMA Mode 5
    PCI (S)ATA/ATAPI Driver@1: PIO Mode 4
    PCI (S)ATA/ATAPI Driver@1: UDMA Mode 5
    sata.device@0: HL-DT-ST DVDRAM GH24NSC0 <CDROM>
    sata.device@1: ATA-HD SanDisk SDSSDHP1 <DIRECT_ACCESS>
    sata.device@1: Mount <DH0>
    sata.device@1: Partition <DH0> DosType 0x444f5307 BootPri 0
    sata.device@1: Mount <DH1>
    sata.device@1: Partition <DH1> DosType 0x53465300
    usbscsi.device@0: Mount <SDH0>
    usbscsi.device@0: Partition <SDH0> DosType 0x444f5307 BootPri 5
    !!! OpenScreen(): Could not find any valid modeids. No graphics card? !!!
    Hello, Ambient here. I couldn't open a screen so I'm trying to
    communicate through the serial port. Hopefully someone can see this.

    Please check the following:
    - working and supported graphics card
    - latest version of the boot.img kernel
    - booting from the correct device
    - driver installed in MOSSYS:Devs/Monitors

    If it still doesn't work, seek help on the MorphOS support mailing-lists
    or contact support@morphos-team.net




    [ Editiert durch metatron 07.07.2015 - 17:31 ]
  • »07.07.15 - 18:23
    Profile
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    Quote:

    Jim schrieb:
    Anyone else find it odd that the Amiga community has to buy firmware updates and video drivers? I guess it is just an indication of how small the market is.



    Please keep this thread free of such discussions. Please...
  • »07.07.15 - 18:29
    Profile
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    Quote:

    bigfoot schrieb:
    What is the PCI device ID of your Radeon X1650?


    Hi bigfoot,

    the ID is: 1002:71c7

    https://pci-ids.ucw.cz/read/PC/1002/71c7
  • »07.07.15 - 18:32
    Profile
  • MorphOS Developer
    bigfoot
    Posts: 381 from 2003/4/11
    Quote:

    metatron wrote:
    Quote:

    bigfoot schrieb:
    What is the PCI device ID of your Radeon X1650?


    the ID is: 1002:71c7


    Thanks. If you can install MorphOS to a hard disk using your Radeon HD 5450, then I can send you an updated Radeon file that will work with your Radeon X1650.

    I'll PM you my email address, then you can email me if you're interested.
    I rarely log in to MorphZone which means that I often miss private messages sent on here. If you wish to contact me, please email me at [username]@asgaard.morphos-team.net, where [username] is my username here on MorphZone.
  • »07.07.15 - 20:25
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    >> Anyone else find it odd that the Amiga community has to buy firmware
    >> updates and video drivers?

    > I suppose you mean OS4-community?

    At least the Sam460 firmware is not OS4-specific.

    > First pay €1000 a Sam system with OS4. Then

    ...request a refund for OS4 and buy MorphOS instead :-)

    http://www.amiga-news.de/en/news/AN-2015-06-00007-EN.html
  • »07.07.15 - 21:04
    Profile
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    Quote:

    bigfoot schrieb:

    Thanks. If you can install MorphOS to a hard disk using your Radeon HD 5450, then I can send you an updated Radeon file that will work with your Radeon X1650.

    I'll PM you my email address, then you can email me if you're interested.


    Morphos is already installed (it only boots with the 5450 though). I will answer your PM immediately.
  • »07.07.15 - 21:20
    Profile
  • Jim
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Jim
    Posts: 4957 from 2009/1/28
    From: Delaware, USA
    Mark is dealing with it, and I'll stop stirring up further dissent between camps.
    After all, its what they always accuse us of, and in the long run it won't make us any friends.

    [ Edited by Jim 07.07.2015 - 19:36 ]
    "Never attribute to malice what can more readily explained by incompetence"
  • »07.07.15 - 21:32
    Profile
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    Got a new monitor file from bigfoot. Now I can boot the sam with the x1650. System runs smooth, but sadly sound is missing.
  • »08.07.15 - 18:28
    Profile
  • Jim
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Jim
    Posts: 4957 from 2009/1/28
    From: Delaware, USA
    Quote:

    metatron wrote:
    Got a new monitor file from bigfoot. Now I can boot the sam with the x1650. System runs smooth, but sadly sound is missing.


    Very Cool.
    A bounty for a better Envy24HT driver might be useful for your second problem.
    And I would be willing to donate PCI and PCI-e cards for that.
    "Never attribute to malice what can more readily explained by incompetence"
  • »09.07.15 - 14:23
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > A bounty for a better Envy24HT driver might be useful for your second
    > problem. And I would be willing to donate PCI and PCI-e cards for that.

    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=11249&forum=11&start=9
    http://translate.google.com/translate?sl=de&tl=en&u=http://www.a1k.org/forum/showpost.php?p=848870
    http://translate.google.com/translate?sl=de&tl=en&u=http://www.a1k.org/forum/showpost.php?p=848989
  • »09.07.15 - 15:55
    Profile
  • Jim
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Jim
    Posts: 4957 from 2009/1/28
    From: Delaware, USA
    Quote:

    Andreas_Wolf wrote:
    > A bounty for a better Envy24HT driver might be useful for your second
    > problem. And I would be willing to donate PCI and PCI-e cards for that.

    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=11249&forum=11&start=9
    http://translate.google.com/translate?sl=de&tl=en&u=http://www.a1k.org/forum/showpost.php?p=848870
    http://translate.google.com/translate?sl=de&tl=en&u=http://www.a1k.org/forum/showpost.php?p=848989


    Yes, probably should have been posted under the first thread.
    Thanks for the later two posts.
    I am not even sure the ZEnvy24HT is the best chip to focus on as it is out of production.
    But, if the SAMN460CR users are using these, well it would be a good excuse to get that straightened out for all platforms.
    "Never attribute to malice what can more readily explained by incompetence"
  • »09.07.15 - 19:07
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    >>> A bounty for a better Envy24HT driver might be useful for your second
    >>> problem. And I would be willing to donate PCI and PCI-e cards for that.

    >> https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=11249&forum=11&start=9

    > Yes, probably should have been posted under the first thread.

    My intention posting this link was to show that pega-1 already explained that it was not just about the audio driver itself but also about the currently incomplete support for the PCIe x1 slot.
  • »09.07.15 - 19:50
    Profile
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    Quote:

    Jim schrieb:

    A bounty for a better Envy24HT driver might be useful for your second problem.
    And I would be willing to donate PCI and PCI-e cards for that.


    Hmm, I am not sure anymore if the soundcard, sold by acube, is really an envy24ht. I had a closer look at some pictures and it looks like it is the cheaper tremor chipset. Envy24ht is VT1724, Tremor is VT1723.
    I dont know if the drivers are compatible in between these two chipsets.

    Maybe they should support a much more common soundcard with a real PCIe interface.

    Btw: I would support a bounty for a new sound driver. But lets think smart about for which soundcard it could be...
  • »09.07.15 - 20:52
    Profile
  • Jim
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Jim
    Posts: 4957 from 2009/1/28
    From: Delaware, USA
    Interesting issues.
    Well, I guess I will stash or sell the Envy24HT card.
    According to past statements I have posted (not going to reference them here), VIA is discontinuing all PCI audio controllers anyway, so Envy and Tremor are dead ends.
    "Never attribute to malice what can more readily explained by incompetence"
  • »10.07.15 - 16:09
    Profile
  • Butterfly
    Butterfly
    metatron
    Posts: 72 from 2011/11/18
    Lets see what happens. I bought myself a new Morphos licence for the sam and sent my "soundcard question" to the support team.
    Maybe a bounty for them can help. Or maybe they're already having plans :)
  • »10.07.15 - 17:45
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11575 from 2003/5/22
    From: Germany
    > maybe they're already having plans :)

    The statements linked to in posting #19 sound like a plan to me :-)
  • »10.07.15 - 21:58
    Profile