Powermac 3.5 no sound...
  • Caterpillar
    Caterpillar
    Posts: 35 from 2015/6/12
    Running MorphOS 3.8 on my G4 800Mhz (PowerMac 3.5) with 768Mb memory but can't seem to get any sound.

    Maybe I have it set to the wrong driver. So if someone could poont me in the right direction.
  • »13.06.15 - 00:41
    Profile
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1321 from 2003/2/24
    From: po-RNO
    Do you have external speakers connected or trying with internal speaker? I had issues with similar PowerMac earlier, but haven't tried with the latest version. I got no sound from internal speaker if I didn't have external speakers with 3,5mm plug connected.. and then I got audio from both.

    PCI audio card should be the final fix if nothing else helps...

    [ Edited by jPV 13.06.2015 - 10:51 ]
  • »13.06.15 - 08:50
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 9433 from 2003/5/22
    From: Germany
    This may be related:

    "MorphOS/Devs/Audiomodes/I2s
    Make behaviour of HeadPhone mute/detect GPIOs manually adjustable via env:applei2s.audio INVHPMUTEGPIO and INVHPDETECTGPIO switches, required for some "PowerMac3,x" models to unmute audio
    "
    http://www.morphos-team.net/releasenotes/3.8
  • »13.06.15 - 12:52
    Profile
  • Caterpillar
    Caterpillar
    Posts: 35 from 2015/6/12
    Its the internal speakers only. I am sure I had sound when I installed from the CD as the installer has a welcome screen music.

    I will have to have a play with the settings see if I can get it back.

    Ironic factor is I recently threw out an SB Live card as I thought I had no use for it...


    [ Edited by zerohour 13.06.2015 - 13:15 ]
  • »13.06.15 - 13:13
    Profile
  • Caterpillar
    Caterpillar
    Posts: 35 from 2015/6/12
    Just plugged in headphones and both worked which is not what I wanted.

    So how do you set the INVHPDETECT/MUTEGPIO switchable.
  • »15.06.15 - 15:59
    Profile
  • MorphOS Developer
    geit
    Posts: 889 from 2004/9/23
    Just copy the line to shell and execute.

    setenv save applei2s.audio "INVHPMUTEGPIO INVHPDETECTGPIO"

    Geit
  • »15.06.15 - 17:09
    Profile
  • Caterpillar
    Caterpillar
    Posts: 35 from 2015/6/12
    Thanks Geit... That has done the trick
  • »15.06.15 - 17:26
    Profile
  • Just looking around
    Chefsessel
    Posts: 8 from 2018/1/5
    on a short note: I ran into the same problem with my PowerMac 3,5. Geit's shell command solved the issue. Thumbs up!
    PowerMac G4 ("Quicksilver"), 733 Mhz, 1234 MB RAM, 64 MB Radeon 9000
  • »07.01.18 - 12:43
    Profile