Pagestream 4 No Text
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    pan1k
    Posts: 147 from 2009/1/20
    I just did a clean install of PageStream 4.09. Same problems. I even added my _ttf folder to font prefs, no dice. I've done every suggestion here. It's getting old, real fast.

    Can someone explain to me, the difference of Morphos:Fonts and Morphos:MorphOS/Fonts to me? (My System drive is MorphOS) Funny thing, when I spell check, it sees the words that I typed in. Would my Display engine settings or font smothing have any effect on it?

    Thanks for everyones help. I'm trying to get PageStream working so I can do some of my wedding invites and labels.
    MacMini 1.5Ghz / Amiga 4000T Cyberstorm 060, 132MB RAM, Cybervision 64/3D, XSurf-III, MP3@64, Buddha Flash / Amiga 1200 GVP 030, Subway USB, 32MB RAM
  • »13.09.14 - 03:03
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 12021 from 2003/5/22
    From: Germany
    > Can someone explain to me, the difference of Morphos:Fonts and
    > Morphos:MorphOS/Fonts to me?

    It's the same as the difference between MorphOS: (aka SYS:) and MorphOS:MorphOS/ (aka MOSSYS:) in general, i.e. the latter contains the private OS fonts while the former is for 3rd party fonts you can install at will.
  • »14.09.14 - 10:14
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1457 from 2012/11/10
    From: Manchester, UK/GB
    Have you the option with Pagestream to update/upgrade to version 4.1.5.6 which was the last release for the Amiga 68k from the v4 release, as it is a much more stable release, and if you get the Pro version there are quite a few advantages to the program if you intend using it for more office/graphics related work.

    Keep trying some other changes to the program, and a CLEAN install - will NOT necessarily get the program working, it will almost certainly require you changing the CSets, and the fonts assign, and more than likely a completely new Pagestream.prefs file, which it will generate itself if you delete or amend to a different name than the one that was created when you installed/registered it.

    I know it is all very 'fiddly' and a nuisance, but it will work, you just have to keep trying options as mentioned, and you will get it working, as I believe most of the MorphOS users who have the program have found it works.

    Good luck. ;-)
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »14.09.14 - 16:05
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    pan1k
    Posts: 147 from 2009/1/20
    Can one of you take a screen shot of your prefs for your fonts? or maybe send a lha or zip of your prefs file for me to test?
    MacMini 1.5Ghz / Amiga 4000T Cyberstorm 060, 132MB RAM, Cybervision 64/3D, XSurf-III, MP3@64, Buddha Flash / Amiga 1200 GVP 030, Subway USB, 32MB RAM
  • »15.10.14 - 05:33
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1457 from 2012/11/10
    From: Manchester, UK/GB
    Here is my un-personalised prefs file for Pagestream4.prefs

    === START ===

    PREFERENCE FILE
    USERNAME "ME - Your own details to be known as"
    USERCOMPANY "Home or work address - your choice"
    USERREGNUM 6DIGIT
    USERPASSWORD 4S5uPlide
    RECENTFILES Documents/yours/wherever.pgs
    SETDIMENSIONS 8.2677" 11.6929" SINGLE PORTRAIT
    SETMARGINGUIDES 0.5" 0.5" 1" 1"
    SETCOLUMNGUIDES 2 0.25"
    DISPLAYDPI 72 72
    SHOWMEMORY TRUE
    SHOWDATE TRUE
    SHOWTIME TRUE
    CENTERONDCLIP TRUE
    SETFONTCACHE 100 50 OPENFONTS 50
    SETFONTPATH PageStream4:Fonts
    SETUNDOLEVELS 60
    SETREVISIONTRACKING OFF
    SETBACKUP AUTOSAVE OFF AUTOBACKUP ON COUNT 3 PATH Documents/Backups
    SETSMART DASHES ON BULLETS ON SINGLEQUOTES ON DOUBLEQUOTES ON
    CHARACTERSET Amiga
    SETFONT Triumvirate-Normal
    SETTYPESIZE 12pt
    SETTYPEWIDTH 100%
    SETLANGUAGE British
    SETPARAGRAPHSTYLE
    SETCHARACTERSTYLE
    SETALIGNMENT LEFT
    SETBOLD OFF
    SETITALIC OFF
    SETUNDERLINE OFF
    SETOUTLINE OFF
    SETREVERSE OFF
    SETSHADOW OFF
    SETSMALLCAPS OFF
    SETSCRIPT OFF
    SETTRACKTABLE NORMAL
    SETTRACKING 0%
    SETLASTLINEFLUSH 0cm
    SETTRACKRANGE -10% 0% 20% 80% 100% 130%
    SETLEADING RELATIVE 120% MAINTAIN OFF
    SETBASELINELEADING RELATIVE 80%
    SETINDENT NONE
    SETFIRSTLINE NONE
    SETPARAGRAPHLEADING BEFORE NONE AFTER NONE
    SETRULEABOVE OFF
    SETRULEBELOW OFF
    SETNUMBERED OFF
    SETBULLET OFF
    SETDROPCAP OFF
    SETTABRULER
    SETDEFAULTTABSTOP 0.847cm
    SETHYPHENATION OFF
    SETHYPHENLANGUAGE DEFAULT DATA 6 3 2 1
    SETKERNING ON KERNABOVE 4pt
    SETLIGATURE ON ANY -20% 20%
    SETHANGING ON
    SETOPTICAL ON
    SETMEASUREMENTS COORDINATE CENTIMETERS SAMEAS RELATIVE SAMEAS TEXT POINTS FROM PAGE
    SETDOUBLECLICK REQUESTER LINEFILL
    SETDUPLICATEDEFAULTS 0.635cm 0.635cm
    SETNUDGEDEFAULTS 0.2cm
    SETLIVEUPDATE SCROLL OFF DRAG OFF
    SETVIEWDEFAULTS SCALE FULLPAGE SCALERANGE 5% 3000% GRID SHOW SNAPTOGRID OFF DISPLAYGRID INBACK GUIDES HIDE SNAPTOGUIDES OFF DISPLAYGUIDES INBACK RULER SHOW PICTURES SHOW DRAWINGS SHOW OUTLINE SHOW TEXTLINKS HIDE INVISIBLES HIDE PAGECOLOR 255 255 255 PAGEBORDERCOLOR 0 0 0 PAGESHADOWCOLOR 170 170 170 PASTEBOARDCOLOR 230 230 230 GRIDCOLOR 0 0 0 PAGEGUIDECOLOR 0 255 255 RULERGUIDECOLOR 255 0 255
    SETAUTOCOLUMNS OFF
    FILEFILTER FALSE
    SETPASTEINCENTER ON
    SELECTONPASTE ON
    SETDOCUMENTPATH Documents
    SETTEXTPATH Text
    SETGRAPHICPATH Graphics
    SETSCRIPTPATH Scripts
    SETSCRATCHPATH Documents/Backups
    SETPDFPATH Documents
    SETMAILMERGEPATH Text
    SETPRINTPATH Documents
    MAINTOOLBOX SHOW AT 0 42 VERTICAL
    SETMAGNIFYINCREMENT 200% DRAGZOOM CENTER
    SETCOLUMNDEFAULTS OPAQUE GUTTER 0.635cm
    SETBOXDEFAULTS CORNER 0.318cm
    SETARCDEFAULTS ANGLES 90° 360°
    SETPOLYGONDEFAULTS SIDES 3 OFFSETANGLE 0° DEFLECTION 40% ANGLEDEFLECTION 50%
    TOOLBAR SHOW AT 0 22
    SETTOOLBAR NEW OPEN SAVEDOC PRINT PRINTSETUP EXPORTTEXT EXPORTGRAPHIC SAVEPDF SPACE INSERTPAGE DELETEPAGE MOVEPAGE CUT COPY PASTE PASTEASIS SELECTALL DELETE FONT SETSTYLE MAKEUPPER MAKELOWER MAKECAPITALIZED SPACE UNDO REDO SPACE LEFT CENTER RIGHT JUSTIFY SPELL LINKTEXT BREAKTEXTROUTING SPACE INDENTLEFT INDENTRIGHT HANGINGINDENT SPACE EXECUTE PREFERENCES SPACE LINEFILL INFORMATION
    SCREEN Public 1280 1024 16 "Radeon9200: 16Bit 1280 x 1024" "Bitstream Vera Sans.font" 15
    SETOUTPUT PostScript
    SETOUTPUT1 SOURCE Tray2 PAPER A4 8.2639" 11.6944" 0" 0" PORTRAIT
    SETOUTPUT2 PPD softlogik:printers/ppd/HP/HP5-ColorLaserJet_PS.ppd SENDTO DEVICE USBPAR:
    SETOUTPUT3 CYANSCREEN DEFAULT DEFAULT MAGENTASCREEN DEFAULT DEFAULT YELLOWSCREEN DEFAULT DEFAULT BLACKSCREEN DEFAULT DEFAULT SPOTSCREEN DEFAULT DEFAULT
    SETOUTPUT4 INCLUDEERRORHANDLER FALSE INCLUDEEOF TRUE
    SETOUTPUT5 FONTUNLOAD DOCUMENT UCR 80% GCR 100%

    === END ===

    Hope this helps, but I tried changing items in my prefs file, but it made no difference, so after changing some other prefs and other files and settings I eventually got Pagestream to work for me under MorphOS v3.1 originally I think it was.

    Since then I have only needed to leave it in place when upgrading so haven't bothered, or needed to change anything about it, so it works really well, though there are the few occasional bits of weirdness that creeps in, but on the whole it functions very well.

    I really hope you get it fixed, but just keep trying something different if this doesn't work, and eventually it will work. I wish I could tell you what it needs to get it to function properly, but I just cannot figure out exactly what it was that resolved my own issues with Pagestream 4, but as others have said it does work, and I just finished using it for the day a few minutes ago, under MorphOS v3.7..
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »16.10.14 - 01:06
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    pan1k
    Posts: 147 from 2009/1/20
    OK.. tried that didn't do anything really.

    How does your fonts prefs look?

    I set my default font drawer to Pagestream4:Fonts like you did.

    Are your font drawers Pagestream4:Fonts/StandardFonts
    Pagestream4:Fonts/Intellifonts
    Pagestream4:Fonts/StudioFonts
    Pagestream4:Fonts/SoftlogikFonts

    Or something else? I see the issue now, it doesn't see my fonts! I tried setting different drawers as my default font drawer and then adding drawers with fonts, no luck. I tried Pagestream:Fonts Pagestream3:Fonts Pagestream4:Fonts Fonts:

    When I removed the default drawers then it saw no fonts. I belive it was /Fonts as the default drawer. Re-adding it back did nothing, fonts did not appear in the list like before.
    MacMini 1.5Ghz / Amiga 4000T Cyberstorm 060, 132MB RAM, Cybervision 64/3D, XSurf-III, MP3@64, Buddha Flash / Amiga 1200 GVP 030, Subway USB, 32MB RAM
  • »18.10.14 - 03:07
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    pan1k
    Posts: 147 from 2009/1/20
    It's working now, at least under Pagestream 4.09. All I had to do was to assign the default drawer to Pagestream:Fonts which didn't work on Pagestream 4.1.5.6 BIG THANKS to all who helped, esp to NewSense!
    MacMini 1.5Ghz / Amiga 4000T Cyberstorm 060, 132MB RAM, Cybervision 64/3D, XSurf-III, MP3@64, Buddha Flash / Amiga 1200 GVP 030, Subway USB, 32MB RAM
  • »18.10.14 - 16:16
    Profile
  • Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1457 from 2012/11/10
    From: Manchester, UK/GB
    I appreciate you thanking me, but I'm just really glad it's now working as it should for you, and that you stuck with trying other things to resolve it. Now you can ENJOY using it. ;-)

    Like everyone else said ...... Pagestream 4 does work with MorphOS .........

    ... but it's a 'pig' to get worked out what exactly you need to change to get it to do what it should from a standard install.

    Why it does that I really cannot say, but I wish Deron Kazmaier would come up with either a replacement installer routine that fixes this issue, as there must be lots of people who would use this program, as it's the best DTP for MorphOS as the moment.

    Additionally, if he spent sufficient time & effort in fixing/de-bugging the versions of Pagestream 5 that he already released, and the MorphOS version that is supposed to be in the pipeline, then we'd have a much better DTP package for MorphOS, and probably for the other Amiga 'like' OS's as well.

    DTP doesn't really need CPU horsepower, just effective code to do what it is supposed to do, and no bugs, preferably.



    [ Edited by NewSense 19.10.2014 - 14:17 ]
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »19.10.14 - 16:15
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    pan1k
    Posts: 147 from 2009/1/20
    Just to tidy up the thread..

    1. I adjusted the default tool for the the installer and made sure it is the supplied installer that comes with Pagestream. By default the MOS installer was running and installing Pagestream

    2. I followed the suggestion of pointing the Default Font Drawer to Pagestream:Fonts and created a "Truetype" folder in the default font drawer for new fonts.

    3. I also emptied the CSets folder and moved everything to 'Disabled'

    Thanks again, just posting here what I did in case someone needs it for future reference.
    MacMini 1.5Ghz / Amiga 4000T Cyberstorm 060, 132MB RAM, Cybervision 64/3D, XSurf-III, MP3@64, Buddha Flash / Amiga 1200 GVP 030, Subway USB, 32MB RAM
  • »19.10.14 - 17:10
    Profile
  • jPV
  • Yokemate of Keyboards
    Yokemate of Keyboards
    jPV
    Posts: 2015 from 2003/2/24
    From: po-RNO
    Quote:

    jPV wrote:
    I had issue that default font didn't give anything, but when I changed to other fonts from the menus, they did work.

    Actually I just checked it and it has some default font which I don't have (or I have some assign or other problem). If I open font selection window and click "Show Sample" it doesn't show anything on it with default font. If I select some other font from the list, it shows sample just fine.... buut then for some reason some of them actually work when trying to write into text box, but some others don't... hmm..


    Finally looked this again, and I got them working now :) I had to open the "File->System Preferences->Fonts..." window from Pagestream and then update all the font drawer paths! Click the Update button for each and save, and then the default font etc do work every time you start the program.

    Here's a screenshot of that window: pagestreamfonts.png
  • »11.04.16 - 15:10
    Profile Visit Website