Problems with SimpleMail 0.40
  • Caterpillar
    Caterpillar
    neoman
    Posts: 33 from 2013/7/29
    From: .de
    Hi,

    I try hard to get SimpleMail 0.40 running but no way. He downloads the folder names but does not download or show *any* message. The lists are just empty. IMAP and SMTP are configured correctly. I use no SSL to avoid problems. I can't send a new mail. I can write it, but when I like on 'Send now' nothing happens.

    Someone got an idea what's going on?!

    Regards,
    neoman
  • »05.06.14 - 22:58
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    emeck
    Posts: 157 from 2014/7/15
    Quote:

    neoman wrote:
    Hi,

    I try hard to get SimpleMail 0.40 running but no way. He downloads the folder names but does not download or show *any* message. The lists are just empty. IMAP and SMTP are configured correctly. I use no SSL to avoid problems. I can't send a new mail. I can write it, but when I like on 'Send now' nothing happens.

    Someone got an idea what's going on?!

    Regards,
    neoman


    I have also some problems with SimpleMail 0.40 with Yahoo Mail and GMail. I've configured Yahoo Mail as is working in my other systems using imap. I can fetch mail and all folders show the mails but I cannot send mail. After about a minute SimpleMail says "Service not ready". That is using SSL. If I uncheck the secure option in the settings, then I get "AUTH failed. User couldn't be authenticated. Please recheck your settings."

    For GMail, it simply won't work. Fetching mail gets the message "Failed to connect to the server".

    I have installed AmiSSL 1.1 and 3.6

    Is anybody using Yahoo Mail or GMail with imap in SimpleMail?
    PowerBook 5.2 MorphOS 3.15
    PowerBook 5.8 MorphOS 3.15
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »11.10.14 - 19:28
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    DanicaTalos
    Posts: 365 from 2010/10/15
    From: 01101110011100...
    Test the 68k Version, not the PPC Version.
    Mac Mini G4 -1,50 GHz - 64MB VRAM - 1GB RAM - 60GB SSD - MorphOS 3.8
    PowerBook G4 - 1,67 GHz - 128MB VRAM - 2GB RAM - 64GB SSD - Kubuntu 12.04
  • »11.10.14 - 22:11
    Profile
  • jPV
  • Paladin of the Pegasos
    Paladin of the Pegasos
    jPV
    Posts: 1921 from 2003/2/24
    From: po-RNO
    68k version (amissl) trashes memory and that's why it's been disabled on PPC version. So you can decide if you take a risk to write crap around or at least being unstable by using 68k version.

    Solution would be that somebody would finally release SimpleMail which is compiled with OpenSSL instead of AmiSSL ;)
  • »12.10.14 - 10:13
    Profile Visit Website
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11715 from 2003/5/22
    From: Germany
    > 68k version (amissl) trashes memory and that's why it's been disabled on PPC version.

    More precisely, it's AmiSSL v3, that's why the PPC version of SimpleMail uses AmiSSL v1.

    https://morph.zone/modules/newbb_plus/viewtopic.php?topic_id=9567&forum=9&start=16
  • »12.10.14 - 10:33
    Profile
  • Caterpillar
    Caterpillar
    neoman
    Posts: 33 from 2013/7/29
    From: .de
    I created a still unreleased (jPv! ;)) OpenSSL-version of SimpleMail which is working quite well here. I know, I still have to release it. I will do it the next days!

    I also fixed a bug with very large IMAP folders and this was the reason why he didn't download the mails. So this is also fixed.

    Release soon - it's for MorphOS only.
  • »12.10.14 - 10:40
    Profile
  • Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Stevo
    Posts: 867 from 2004/1/24
    From: #AmigaZeux
    Quote:

    neoman wrote:
    I created a still unreleased (jPv! ;)) OpenSSL-version of SimpleMail which is working quite well here. I know, I still have to release it. I will do it the next days!

    I also fixed a bug with very large IMAP folders and this was the reason why he didn't download the mails. So this is also fixed.

    Release soon - it's for MorphOS only.



    Much appreciated :)
    ---
    http://www.iki.fi/sintonen/logs/its_only_football.txt
  • »12.10.14 - 12:26
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    roschmyr
    Posts: 206 from 2003/2/20
    From: Oberhausen/Ger...
    Quote:

    neoman schrieb:

    Release soon


    that would be nice/cool

    [ Editiert durch roschmyr 12.10.2014 - 14:15 ]
  • »12.10.14 - 15:15
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    emeck
    Posts: 157 from 2014/7/15
    @DanicaTalos
    Quote:

    DanicaTalos wrote:
    Test the 68k Version, not the PPC Version.


    Thanks for the suggestion, but 68k version says "Failed to connect to the server", so worse than PPC version here.

    I'll keep trying.
    EDIT: Forgot to reinstall AmisSSL v3 defore trying the 68k version. Yahoo Mail is working now, fetching and sending. Thanks!

    EDIT 2: GMail is also working now.

    [ Edited by emeck 12.10.2014 - 17:58 ]
    PowerBook 5.2 MorphOS 3.15
    PowerBook 5.8 MorphOS 3.15
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »12.10.14 - 17:28
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    emeck
    Posts: 157 from 2014/7/15
    @neoman
    Quote:

    neoman wrote:
    I created a still unreleased (jPv! ;)) OpenSSL-version of SimpleMail which is working quite well here. I know, I still have to release it. I will do it the next days!

    I also fixed a bug with very large IMAP folders and this was the reason why he didn't download the mails. So this is also fixed.

    Release soon - it's for MorphOS only.


    That will be great! Thank you for working on it.
    PowerBook 5.2 MorphOS 3.15
    PowerBook 5.8 MorphOS 3.15
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »12.10.14 - 17:29
    Profile
  • Caterpillar
    Caterpillar
    neoman
    Posts: 33 from 2013/7/29
    From: .de
    I also tried to reach the authors but unfortunately I got no answer.

    Also there is a huge flaw in the OpenSSL implementation because I chose a quite naive way to create the random numbers for the key exchange in OpenSSL. I still have to replace that with a proper implementation.

    I'm going to commit it here: https://code.google.com/p/simplemail-mos/

    I will surely provide a MOS build, too.
  • »12.10.14 - 20:31
    Profile
  • Caterpillar
    Caterpillar
    neoman
    Posts: 33 from 2013/7/29
    From: .de
    Hello folks,

    I prepared an initial release of my MOS version of SimpleMail with OpenSSL and fixed support for huge IMAP folders. For sure I like to make more changes, so if you have any ideas, don't hesitate to ask.

    I tested with my mail servers (all Postfix based) - what didn't work, was a direct (old) SSLv2 connection to Postfix SMTPS (port 465) - not sure why this isn't working yet. All TLS stuff seems to work (even with STARTTLS). Also tested Google Mail but you have to enable Google Mail and allow "less secure apps" ( https://www.google.com/settings/security/lesssecureapps ) I'm still working on supporting this though. Also I had to replace the OpenSSL internal RNG by a quite bad PRNG. I have to use better random numbers to make it as secure as possible.

    https://code.google.com/p/simplemail-mos/

    Enjoy - on that site is the source and a download link.
  • »26.10.14 - 21:22
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Debaser
    Posts: 161 from 2005/7/12
    From: Syracuse, NY, USA
    Thanks for your work neoman. I can now get somewhere with Simplemail and my Gmail account via POP3. I now get a pop up notification about a certificate error, and then I must click on the <connect anyway> button, but I am able to send and receive email messages.

    I will wait for further improvements but again, great work.
  • »26.10.14 - 23:35
    Profile
  • Caterpillar
    Caterpillar
    neoman
    Posts: 33 from 2013/7/29
    From: .de
    Yeah I noticed that. It's because the public certificate authorities are not imported into OpenSSL. I will add them. Also I need a way to store accepted certifcates so one can connect to own mail servers via SSL without verify check.

    Another change I will make for the next release is a real IMAP folder tree with subfolders.
  • »27.10.14 - 07:14
    Profile
  • Caterpillar
    Caterpillar
    neoman
    Posts: 33 from 2013/7/29
    From: .de
    Okay,I made more fixes today in version 1.01:

    https://code.google.com/p/simplemail-mos/
    http://amigapurist.scenespace.net/simplemail-mos/simplemail-mos-1.01.lha

    With this version common root CAs are supported (Google Mail etc.).
    Also self-signed certs can be validated permanently now.

    So SSL can be used quite flawlessly now.
  • »27.10.14 - 15:48
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Debaser
    Posts: 161 from 2005/7/12
    From: Syracuse, NY, USA
    Neoman - Great work! Thanks for this new version - certificate issues gone and works great.
  • »27.10.14 - 21:21
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    emeck
    Posts: 157 from 2014/7/15
    Quote:

    neoman wrote:
    Okay,I made more fixes today in version 1.01:

    https://code.google.com/p/simplemail-mos/
    http://amigapurist.scenespace.net/simplemail-mos/simplemail-mos-1.01.lha

    With this version common root CAs are supported (Google Mail etc.).
    Also self-signed certs can be validated permanently now.

    So SSL can be used quite flawlessly now.


    Thank you! Downloaded and configured yahoo mail and gmail, both as IMAP. Fetching and sending works, and is fast.

    I'll keep testing and report any issues.
    PowerBook 5.2 MorphOS 3.15
    PowerBook 5.8 MorphOS 3.15
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »27.10.14 - 21:23
    Profile
  • Caterpillar
    Caterpillar
    neoman
    Posts: 33 from 2013/7/29
    From: .de
    A new day, a new release 1.1, beta for now, because I'm not sure if I got the hostname validation completely right. But I also added other features:

    - Added hostname verification
    - Added Checkboxes to allow SSLv2/V3 in Configuration/Receive Mail
    - Added real IMAP folder tree with arbitrary depth

    https://code.google.com/p/simplemail-mos/
    http://amigapurist.scenespace.net/simplemail-mos/simplemail-mos-1.1beta.lha

    Piru: What is your setup for a man in the middle attack so I can properly test it?
  • »28.10.14 - 14:45
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    emeck
    Posts: 157 from 2014/7/15
    Hi neoman,


    I've been using release 1.1 beta for my gmail and my yahoo imap accounts. I want to ask/report some things.

    The first one is about the folder properties. It seems they are not saved. If I change the type and primary sort, for example, it works as long as I don't close SimpleMail. Every time I start it, the folder properties are unchanged.

    Is that happening to other users or am I doing something wrong?

    Quote:

    neoman wrote:
    A new day, a new release 1.1, beta for now, because I'm not sure if I got the hostname validation completely right.
    PowerBook 5.2 MorphOS 3.15
    PowerBook 5.8 MorphOS 3.15
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »18.11.14 - 12:16
    Profile
  • Caterpillar
    Caterpillar
    neoman
    Posts: 33 from 2013/7/29
    From: .de
    Hey emeck,

    yeah I can check and try to fix that. Would be nice if you can create some issues on

    https://code.google.com/p/simplemail-mos/issues/list

    too! Thanks a lot! :)
  • »20.11.14 - 20:11
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    emeck
    Posts: 157 from 2014/7/15
    Ok, thank you neoman

    I'll report this and 2 other issues I have.

    Quote:

    neoman wrote:
    Hey emeck,

    yeah I can check and try to fix that. Would be nice if you can create some issues on

    https://code.google.com/p/simplemail-mos/issues/list

    too! Thanks a lot! :)
    PowerBook 5.2 MorphOS 3.15
    PowerBook 5.8 MorphOS 3.15
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »20.11.14 - 21:34
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    emeck
    Posts: 157 from 2014/7/15
    @neoman
    Quote:


    https://code.google.com/p/simplemail-mos/issues/list

    I've added the issue and 2 more (those 2 maybe be related). I hope the explanation is clear. If you need more info I'll be glad to help.

    Thanks for your support!
    PowerBook 5.2 MorphOS 3.15
    PowerBook 5.8 MorphOS 3.15
    Amiga 1200 BPPC/BVision AOS4.1 FE
  • »23.11.14 - 18:21
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    matt3
    Posts: 477 from 2004/2/10
    I have a problem with the latest fork of Simplemail.

    I replaced the images with a new high res toolbar set from aminet and they will not display. I played with MUI the bar settings with no luck. The appicon works perfectly, not the toolbar only text shows.

    http://aminet.net/package/comm/mail/fingus_smtb

    Any ideas?
  • »26.11.14 - 03:12
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    matt3
    Posts: 477 from 2004/2/10
    I tested with Simplemail 68k and the images don't work their either... So this isn't specific to the new fork.
  • »26.11.14 - 21:58
    Profile
  • Yokemate of Keyboards
    Yokemate of Keyboards
    Andreas_Wolf
    Posts: 11715 from 2003/5/22
    From: Germany
    > I will surely provide a MOS build, too.

    Seems someone mistakes you for Henes:

    http://www.amigafuture.de/album_pic.php?pic_id=20615 ;-)
  • »07.01.15 - 19:54
    Profile