Graphic bug 16bit with Radeon 9800
  • Butterfly
    Butterfly
    Georg
    Posts: 90 from 2004/4/7
    Do MOS gfx drivers have options to disable hw accelerated paint functions (like rect filling, template blitting)? If yes, then seeing the screenshot, that's the first thing I would try.
  • »19.06.22 - 18:21
    Profile
  • MorphOS Developer
    bigfoot
    Posts: 427 from 2003/4/11
    Quote:

    bigfoot wrote:

    However there is one thing you can do. I of course can't promise that it'll lead to anything at all, but if you or anyone else who has a card affected by this problem can open up the GraphicsBoards utility and take a screenshot of it (while using the affected card, of course), then maybe that could give me a hint.


    Looks like we need some extra incentive to get the required screenshot, so the first person to provide me with the requested screenshot will, if the screenshot confirms my suspicion, receive a test version of the Radeon monitor that might solve the problem.
    I rarely log in to MorphZone which means that I often miss private messages sent on here. If you wish to contact me, please email me at [username]@asgaard.morphos-team.net, where [username] is my username here on MorphZone.
  • »23.06.22 - 08:44
    Profile Visit Website
  • Caterpillar
    Caterpillar
    eastone
    Posts: 38 from 2007/8/4
    From: Vaasa/Finland
    Hi Bigfoot,
    I replaced the 9650 with a flashed 9800 pro 128MB and I put a screenshot and a photo here. While the graphicsboards utility window looks fairly well on a 16bit screen, the screenshot is unreadable.
    And this is all on a freshly updated system from 3.16 to 3.17 on MDD 1.33 with 2gb ram.
    Radeon is hooked up by DVI cable if is matter.

    https://drive.google.com/drive/folders/1VU6VnMJ6h4AJ2Zz6QblqFGXSZBIM0aio

    [ Edited by eastone 23.06.2022 - 13:34 ]
  • »23.06.22 - 10:22
    Profile
  • MorphOS Developer
    bigfoot
    Posts: 427 from 2003/4/11
    Quote:

    eastone wrote:
    Hi Bigfoot,
    I replaced the 9650 with a flashed 9800 pro 128MB and I put a screenshot and a photo here. While the graphicsboards utility window looks fairly well on a 16bit screen, the screenshot is unreadable.
    And this is all on a freshly updated system from 3.16 to 3.17 on MDD 1.33 with 2gb ram.

    https://drive.google.com/drive/folders/1VU6VnMJ6h4AJ2Zz6QblqFGXSZBIM0aio


    Thanks, that's fairly interesting, actually. Just to make sure I understood this correctly: In reality, when you look at the screen, the GraphicsBoards window looks OK, but the Ambient background is distorted, but with a screenshot taken from within MorphOS, it's the opposite and the GraphicsBoards window is distorted, but the Ambient background looks OK?

    What program did you use for taking the screenshot?
    I rarely log in to MorphZone which means that I often miss private messages sent on here. If you wish to contact me, please email me at [username]@asgaard.morphos-team.net, where [username] is my username here on MorphZone.
  • »23.06.22 - 10:36
    Profile Visit Website
  • Caterpillar
    Caterpillar
    eastone
    Posts: 38 from 2007/8/4
    From: Vaasa/Finland
    On the ambient screen icons seem to be okay, the rest is a psychedelic mix of colors.
    In the screenshot of the entire screen GraphicsBoards window looks almost fine except for the slider and the top bar.
    The screenshot of the window itself is unreadable.

    The screenshot is made by the system grabber.

    I hope this is somewhat clarified ;)

    [ Edited by eastone 23.06.2022 - 14:47 ]
  • »23.06.22 - 11:02
    Profile
  • MorphOS Developer
    bigfoot
    Posts: 427 from 2003/4/11
    Haha, sorry, that unfortunately didn't clear up the confusion :)

    Your link has two images. One seems like it's taken with a camera, the other looks like a regular screenshot. The two images seem to have opposite areas of the screen being correct and distorted.

    For example, on what looks like a camera image, the Ambient background image is distorted, but on the screenshot, it looks normal.

    So I just wanted to make sure here that I am indeed assuming right, that the first photo is a camera photo, and the second one a screenshot taken from within MorphOS, and both are taken of the same system, with the same configuration.

    As for the system grabber, you mean the Grabber program found in sys:Utilities/Grabber, right? As opposed to the grabber screenbar, which is a different thing.
    I rarely log in to MorphZone which means that I often miss private messages sent on here. If you wish to contact me, please email me at [username]@asgaard.morphos-team.net, where [username] is my username here on MorphZone.
  • »23.06.22 - 11:09
    Profile Visit Website
  • Caterpillar
    Caterpillar
    eastone
    Posts: 38 from 2007/8/4
    From: Vaasa/Finland
    System running in 16bit mode:
    - panel / dock disappears from the screen
    - icons on the desktop are fine
    - the wallpaper and Ambient top bar have wrong colors
    - the contents of the GraphicsBoards window or e.g. system preferences is ok
    - scrennshots look like I described above

    And now:
    SCREENSHOTS taken in 16bits now look different when opened on the screen in 24bits
    - wallpaper looks normal
    - icons now have wrong colors
    - content of windows that previously looked normal now have wrong colors
    - the upper ambient top bar has the colors ok, but the text is distorted and, for example, the processor module has wrong colors

    I don't know how to better describe it.

    To be more precise, I took screenshots with a grabber as a module of the top bar and garbber from sys: Utilities / Grabber. In both cases results are the same.

    [ Edited by eastone 23.06.2022 - 15:20 ]
  • »23.06.22 - 11:12
    Profile
  • MorphOS Developer
    bigfoot
    Posts: 427 from 2003/4/11
    OK, thank you, that last edit gave me all I need to know for now I think :)
    I rarely log in to MorphZone which means that I often miss private messages sent on here. If you wish to contact me, please email me at [username]@asgaard.morphos-team.net, where [username] is my username here on MorphZone.
  • »23.06.22 - 12:21
    Profile Visit Website
  • MorphOS Developer
    bigfoot
    Posts: 427 from 2003/4/11
    I sent you a private message with a link to an updated Radeon file for you to try.
    I rarely log in to MorphZone which means that I often miss private messages sent on here. If you wish to contact me, please email me at [username]@asgaard.morphos-team.net, where [username] is my username here on MorphZone.
  • »23.06.22 - 12:44
    Profile Visit Website
  • Caterpillar
    Caterpillar
    eastone
    Posts: 38 from 2007/8/4
    From: Vaasa/Finland
    You are genius, Mark :)
    Thank you very much for your hard work!

    https://drive.google.com/file/d/15BDowj_QutFhn-YAV4-YQ8qrbvU3Y8Vi/view?usp=sharing
  • »23.06.22 - 12:59
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    MoerBoer
    Posts: 175 from 2019/10/15
    Nice one!
  • »23.06.22 - 13:04
    Profile
  • Order of the Butterfly
    Order of the Butterfly
    Divinity
    Posts: 498 from 2009/9/8
    all good here too! thanks Mark
  • »24.06.22 - 14:07
    Profile