Help bubble delay is wrong
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Samurai_Crow
    Posts: 112 from 2009/12/10
    From: Minnesota, USA
    Under Ambient MUI, I set the help bubble delay to 5 seconds but they pop up after only 2 seconds regardless of the preference setting. I can turn them off with the checkbox but I was hoping just to make them less obtrusive rather than get rid of them completely. Is this a bug or a feature gone wrong?

    EDIT

    I forgot to mention this is on a silent upgrade Mac Mini with registered MorphOS 3.13.

    [ Edited by Samurai_Crow 30.05.2020 - 09:15 ]
  • »30.05.20 - 16:14
    Profile
  • ASiegel
    Posts: 1234 from 2003/2/15
    From: Central Europe
    What is the difference between a "bug" and a "feature gone wrong"? :-)

    But yeah, it sounds like a bug at least.
  • »31.05.20 - 17:30
    Profile
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Samurai_Crow
    Posts: 112 from 2009/12/10
    From: Minnesota, USA
    Quote:

    ASiegel wrote:
    What is the difference between a "bug" and a "feature gone wrong"? :-)

    A bug is unintended. A feature gone wrong is deliberate but still bad. :-)

    Quote:

    But yeah, it sounds like a bug at least.

    Is there a better place to report little "paper cut" bugs?
  • »01.06.20 - 17:48
    Profile
  • ASiegel
    Posts: 1234 from 2003/2/15
    From: Central Europe
    Please use the bug reporting tool included with MorphOS. As far as I can tell, nobody else has reported the same issue so far.
  • »01.06.20 - 18:33
    Profile
  • MorphOS Developer
    jacadcaps
    Posts: 2094 from 2003/3/5
    From: Canada
    And since we're talking about bug submissions: in general, make sure that you can be contacted using the information provided in the bugreport. We have a lot of issues in our DB that do not get looked into because we did not receive enough information and the author of the report cannot be contacted (since there's no irc nickname or email in the ticket).
  • »01.06.20 - 19:15
    Profile Visit Website
  • Acolyte of the Butterfly
    Acolyte of the Butterfly
    Samurai_Crow
    Posts: 112 from 2009/12/10
    From: Minnesota, USA
    I found it in the Support tab of About MorphOS menu option in Ambient. Bug report sent and more specifically than the first one.
  • »02.06.20 - 13:06
    Profile
  • MorphOS Developer
    cyfm
    Posts: 404 from 2003/4/11
    From: Germany
    Thanks for submitting the bugreport.
    It turned out that it actually is a "feature" related to all the "help"/info bubbles related to icons and/or icon views.
    You will notice that the standard MUI Help Bubble Delay is applied to e.g. Ambient's settings window help bubbles but all windows or views related to icons have a custom delay setting which is actually way shorter if you prefer to use e.g. a 5s delay.
    This must have been a decision way back when Ambient was originally created.
    There is currently no way to adjust this Ambient info bubble default delay setting for icon views. This might change for a future release.
  • »03.06.20 - 12:59
    Profile Visit Website