• Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Posts: 543 from 2007/8/6
    From: Pending...
    I think I tried 10.10 when I first got my powerbook. If I recall, it didn't fit on the cd... But anyway, I've since installed 12.04. It's got some weird graphics corruption issues (moreso than 10.04) at startup and shutdown but, once the desktop is loaded, it's fine. Except for Unity - which is what drove me from x86 Ubuntu to Mint... btw Aren't the x.10 Ubuntu releases somewhat experimental?

    Instead of trying to figure out all the partitions needed for three OSes and setting them up with Disk Utility in OS X, this time I tried a more minimalistic approach. I still used Disk Utility, because the OS X install process seems much more likely to derail if the user dares to partition the drive with any other partitioning program, but only to create the OS X and MorphOS Boot partitions. I did this from the OS X install dvd so I had to quit the install in a fairly inelegant manner in order to install MorphOS first. I'm not sure what triggers it but I didn't want to wait through another OS X install only to find that double partition entry bug in the MorphOS installer again. With only two pre-existing, empty partitions, the MorphOS installer behaved as expected. Although it seemed somewhat difficult to convince MorphOS to change the Boot partition type to simple HFS... However, I was able to get Boot formatted correctly with a combination of Mounter, HDConfig and Format. With MorphOS installed, I picked up where I left off with the OS X install dvd - no problem there. I'd left most of the drive as free space so I then used some of that at the end of the drive for Ubuntu. The Ubuntu installer has three options - Whole drive, Side-by-side with OS X and Something else. Side-by-side may have worked but I went with Something else. Using the Ubuntu installer in this way, I was unable to set mount points for the bootstrap and swap partitions. I was still able to set the root mount point and somehow the installer managed to complete. Rather than mess around with yaboot, which is a cumbersome process, I just changed the Open Firmware boot-device back to MorphOS and use alt-boot for OS X or Ubuntu.

    [ Edited by ausPPC 12.02.2013 - 07:07 ]
    PPC assembly ain't so bad... ;)
  • »11.02.13 - 21:02
    Profile Visit Website