• Order of the Butterfly
    Order of the Butterfly
    Posts: 158 from 2019/4/6
    @zukow,
    Hi,

    The fix I guess is due to the error
    libusb_release_interface: -4 [NO_DEVICE]
    which occurred before effectively blocking Morphos when the audio-usb was inserted
    and now it no longer occurs.

    For the rest I don't understand why those who develop qemu don't buy this:
    AMAZON:
    https://tinyurl.com/5n7ue6xd <---- 7.99 EUR

    and debug or something else.

    I have not used linux for 20 years and I do my best to spend a few hours of time.

    here the author's answer:
    It turns out there's a limitation in QEMU's OHCI emulation that likely causes problems for devices with multiple endpoints such as audio interfaces with buttons (like when you see both audio and hid classes attached to the USB device) or maybe audio interfaces in general so these likely won't work with machines using OHCI (eg mac99 and sam460ex) until somebody fixes this in the QEMU device emulation. (This was discussed on the qemu-devel list end of last year but I don't have a link now.)
    The pegasos2 uses a different USB controller (UHCI) which had a separate problem but I've fixed that in latest 6.2.0 version so you may try with that instead as it may work better or at least have better chnace of working than the known incomplete OHCI emulation. So if you're still interested, please test with the pegasos2 machine and let us know.

    for Pegasos 2 here are some tips from the author:
    You definitely don't have to do modprobe on your host OS, in fact you need to do the opposite and make sure NO driver is loaded by the host foir the device so the guest driver can fully control it. Otherwise host and guest drivers may both access it which will not work. Maybe try to do lshw as root on your host OS and check that the device is claimed by any driver then unload that driver with modprobe -r or rmmod and once it's unclaimed then try to use it from QEMU. If you cannot unload the driver because the audio device is opened by some service such as pulsaudio you may need to stop those first or better add an udev rule to ignore the device so when you plug it in no driver is loaded then the guest can use it excusively.

    In fact I have blacklisted the UDEV device and also disabled pulse on the usb-audio device
    but it doesn't seem to work.

    It's probably not clear to me what he means by the advice he probably gave me.
    Because the problem remains, the device is connected but in fact it is not seen as a usb-audio device as opposed to Sam460ex which actually recognizes it and saves the device but then the sound is not heard.

    Some idea?

    I always remain of the idea that if the thing is feasible, the purchase of the usb-audio stick by the developer is the best choice
    AMAZON:
    https://tinyurl.com/5n7ue6xd <---- 7.99 EUR
    :-)

    since there are,
    thank's for your job,
    I find Morphos a really nice system :-)

    [ Edited by white 01.02.2022 - 16:14 ]
  • »01.02.22 - 15:10
    Profile