• Paladin of the Pegasos
    Paladin of the Pegasos
    NewSense
    Posts: 1480 from 2012/11/10
    From: Manchester, UK/GB
    Quote:

    jacadcaps wrote: As others have pointed out, it's most likely a USB issue. . .]

    I've not had a problem that I'm aware of with the USB2 connected SATA HDD - but obviously as/when I've had "crashes" with Wayfarer then maybe this affected a file/part of a file in the cache, but so far all has been great with v2.3 ! :-D

    I don't intend to put Wayfarer on my main system HDD as yet, but I feel it's almost time to do so, and I take on board yours and others comments about using USB2 for such intensive small file(s) transfer/loading.
    Quote:

    jacadcaps wrote: Loaded https://www.formula1.com/en/latest/video.race-highlights-2021-austrian-grand-prix.1704370404771962147.html just now on a 1.5GHz mini. Waited for page to load (until CPU goes down), then Settings menu > www.formula1.com >
    - Media Playback: on
    - Media Source Playback: on
    - Require User Gesture: on (that's important)
    - HLS Streaming: on
    - VP9: off (you really don't want VP9 OFF a mini, it's way too slow)
    - HVC: off (it's also way too slow on a mini)
    - Decode video: on
    - Spoofing: Wayfarer

    Most of those settings were as commented above, but I had Spoofing/User Agent set as Safari - why select Wayfarer?

    Also, that option for Require User Gesture was OFF - but why must "Require User Gesture: ON? As I don't see any User Gesture required as such before it starts to play the video, please explain why this is so important? :-?

    Frankly I would never have thought to have the Require User Gesture set to on, as I would never have thought that was important for audio to work, or for whatever it achieves. As I never realised there was any "gesture" I needed to take or action I took to make audio get triggered, even now when I do get audio playing on the Formula 1 videos - thanks to your great options/advice. 8-D

    Just a query regarding other sites that have video that will require audio output - should all such sites, i.e. YouTube, have the Require User Gesture - set to ON (just in case that setting is as important as it is on Formula 1), and should the User Agent be set to Wayfarer, or any other settings that are necessary for such sites.

    Ideally a better breakdown of what the menu/settings options do to trigger video/audio codecs on such webpages would probably help understand what is needed to be set on/off for a webpage by webpage basis.
    Quote:

    jacadcaps wrote: If it's still too slow, put Wayfarer on a faster drive. Loading websites writes a LOT of data to a drive and using a slow medium like USB will negatively impact performance at a time when you already have no margin left, if only because USB I/O normally needs more CPU than regular HDD I/O.

    I find that even with the USB2 SATA HDD the data is spooled quickly enough, and the videos play through almost seamlessly, with audio - within the limitations I expected (SD video), but I'll bear in mind the advice about using Wayfarer from the system IDE channel in the future, but for now it's entirely acceptable - thanks. 8-)
    Quote:

    jacadcaps wrote: I'll look into why there's no sound when spoofing as Safari/iOS when I have the time. Edit: after a quick analysis of the HLS stream (the one you get with Safari/iOS), turns out this is a special case (oh joy) where the audio is a separate HLS sub-stream. No promises on whether this is ever going to be supported, as it's a lot of extra work for a single website.

    For me, as long as I know which options to choose to make it work then I'm happy with that, it was just the obvious disappointment of watching a video with no audio - that's now solved - which is great, so for me v2.3, along with your great advice/settings, is a good step forward. :-D
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »09.07.21 - 00:35
    Profile