• Paladin of the Pegasos
    Paladin of the Pegasos
    Posts: 1475 from 2012/11/10
    From: Manchester, UK/GB
    On 20-Jan-2019 I tried to access a page on ebay, my Selling page which links to Draft listing, so I clicked on the Saved Drafts link, which took me to the - New Drafts Page, where I found an overlaid area with a "X" close gadget, and a click-on "OK, got it" area, these "buttons" are not triggered/closed/actioned by OWB, as they just don't do anything. They change colour as they probably should, but no "spoofing" seems to alter/activate the overlaid area of code to allow the area to close as it should.

    I did manage to get past the code by interrogating the code on the page, and by deleting a couple of nodes that seem to hold the code in place, which then removed the overlaid area and thus allowed me to access the main page 'below'.

    This issue relates to both the MorphOS v3.11 release that included OWB v1.25, and the later JIT enabled release by bigfoot.

    Anyway, today 12-Feb-2019 I clicked on a "Leave Feedback" item, and the page loaded, and the fields of the page loaded as they usually do, but when the "Leave Feedback" button is clicked on the button appears to have been triggered but the data is not transferred to the website. There is some CPU activity as though it is actioning some JavaScript to action the response, but the code is not meeting the requirements of the website and so the "Feedback" cannot be left.

    Then I worked out that I was able to "Leave Feedback" yesterday 11-Feb-2019 for numerous items but today the page is unresponsive, which seem to be the second page that now seems to be non-functional. So, I checked the versions I have, and this unresponsiveness ONLY applies when using OWB v1.25 JIT release 1 or 2 as supplied as the separately released v1.25 JIT coded by bigfoot.

    The OWB release v1.25 that was included with MorphOS v3.11 is unaffected on that Feeback page on ebay, and allows you to leave feeback as normal, which is presumably the version I was using when I left feedback successfully.

    Following a suggestion by ASiegel I also tried de-activating the Content Blocking option in preferences, but with no effect.

    I have also noticed that the Watch List page is also unresponsive. If an item is required to be removed from your Watch List by "ticking" the box at the side of the item, it usually triggers the "Delete" option button, which is initially "ghosted" grey but on clicking on an item then turns solid blue, but this no longer occurs, and so you cannot delete an item from your Watch List by this method.

    Also, the drop-down option button that is titled "I'd like to .." also does nothing, which used to offer additional options such as, "view similar items" but is now inaccessible/does not respond, or even highight when the mouse hovers over the button, with any of the versions of OWB that I have. So this is a third page/issue that is affecting the current version of OWB.

    If you try to add an item to your Watch List then I have noticed that it does not always get added to the "Watch List" any more, though generally speaking this does work correctly with OWB v1.25 as supplied with MorphOS v3.11, and with the initial Level 1 JIT release, and the 2nd JIT release by bigfoot, but will probably be affected by updates to eBay's codebase for their webpage in the not too distant future - as it relates to "Watching" items, and the "Watch List" page(s)..

    However, you can ADD or DELETE items via "My eBay Summary" page and either delete them individually or by "ticking" the box at the side of the item, and then select the "Delete" button, which then will delete the "ticked" items by the normal methods from your Watch List.

    However, how long this will continue to be possible, as eBay are certain to realise that the "My eBay Summary" page does not work like the "Watch List" page and will update their site pages so that all items are deleted through the same code/method, and then what do we do if this is still the case with OWB at that time?

    These all seem to be limitations of OWB v1.25 as supplied with release MorphOS v3.11 and also applies when using OWB v1.25 JIT release 1 and 2 as supplied as the separately released v1.25 JIT coded by bigfoot..

    I feel sure there will be other issues I have not yet identified that limit OWB v1.25, with either or both the official MorphOS v3.11 release, and/or the JIT enabled bigfoot releases, but I mention it for other MorphOS users to be aware of, and for the MorphOS Team to be aware of this issue to resolve it. I haven't sent it in as a bug, as I don't suppose it is, but it is certainly a limitation of what OWB v1.25 is capable of as standard, without editing/changing the code of a webpage.

    I have submitted a bug report regarding this erroneous behaviour with OWB.

    [ Edited by NewSense 13.02.2019 - 01:05 ]
    MacMini 1.5GHz,64MB VRAM, PowerBooks A1138/9 (Model 5,8/9),PowerMac G5 2.3GHz(DP), iMac A1145 2.1GHz 20", all with MorphOS v3.18+,Airport,Bluetooth,A1016 Keyboard,T-RB22 Mouse,DVD-RW-DL,MiniMax,Firewire/USB2 & MacOSX 10.4/5
  • »12.02.19 - 01:46