• MorphOS Developer
    bigfoot
    Posts: 326 from 2003/4/11
    Quote:

    eliot wrote:
    Hmm,

    for me bigfoots script does not work on Ubuntu 19.10 for some reasons.
    I have changed some lines, but now compilation of ggc9 fails with really trivial
    error (missing stdio.h).


    Yes, it fails because of those changes :)

    Quote:

    What I needed to change in bigfoots script:
    - it checks for an sdk lha archive (don't know if exists anywhere,
    but on morphos site there is only this archive sdk-source-20191006.tar.xz)
    I removed the lha parts because they don't seem to be required


    The lha archive is required. It's on the MorphOS website. It's the regular SDK download, and it contains, among other things, stdio.h

    Quote:

    - make for gcc is called CFLAGS -m32 set. As I remember correctly, a 32 bit
    env is not required anymore, so I also removed this argument


    Only if it detects you're building an old SDK with an old version of Binutils that doesn't work when compiled in 64 bit mode, which won't be the case if you're compiling the latest SDK. No need to change that.

    Quote:

    In the end I get the error above.
    I don't know if the correct script was put to public.


    It was. It just requires you to supply it with both files it needs, and to not make modifications to it.
    I rarely log in to MorphZone which means that I often miss private messages sent on here. If you wish to contact me, please email me at [username]@asgaard.morphos-team.net, where [username] is my username here on MorphZone.
  • »19.10.19 - 07:00
    Profile Visit Website