• MDW
  • Order of the Butterfly
    Order of the Butterfly
    MDW
    Posts: 198 from 2003/7/25
    From: Wroclaw/Poland
    I try to build ffmpeg or libav for MorphOS but I have problems. I can’t compile because configure script is not finished with success.

    I removed from script:
    Code:
    check_cflags -fdiagnostics-color=auto
    check_disable_warning -Wno-maybe-uninitialized

    because these options are unrecognized on MorphOS.

    If I call:
    Code:
    configure --enable-nonfree --enable-version3 --disable-yasm --disable-asm --disable-inline-asm --arch=ppc74 --target_os=none --disable-optimizations

    the script is working about 2-3 minutes (on G4/1,67) and the process stops. There are no error, no message, no info what happened. Process is not finished because there are no expected results.

    I see in CLI:
    Code:
    Broken pipe - od

    but this appears on the beginning of the process (after that script is working).

    Last lines of generated config.log (about 220KB):
    Code:
    gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_DEFAULT_SOURCE -std=c99 -maltivec -mabi=altivec -g -Wdeclaration-after-statement -Wall -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wstrict-prototypes -Wno-parentheses -Wno-switch -Wno-format-zero-length -Wno-pointer-sign -fno-math-errno -fno-signed-zeros -fno-tree-vectorize -Werror=implicit-function-declaration -Werror=missing-prototypes -Werror=return-type -Werror=declaration-after-statement -c -o /tmp/ffconf.oWmsur1C.o /tmp/ffconf.eudlhu2d.c
    check_cflags -Werror=vla
    test_cflags -Werror=vla
    check_cc -Werror=vla
    BEGIN /tmp/ffconf.eudlhu2d.c
    1 int x;
    END /tmp/ffconf.eudlhu2d.c
    gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_DEFAULT_SOURCE -std=c99 -maltivec -mabi=altivec -g -Wdeclaration-after-statement -Wall -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wstrict-prototypes -Wno-parentheses -Wno-switch -Wno-format-zero-length -Wno-pointer-sign -fno-math-errno -fno-signed-zeros -fno-tree-vectorize -Werror=implicit-function-declaration -Werror=missing-prototypes -Werror=return-type -Werror=declaration-after-statement -Werror=vla -c -o /tmp/ffconf.oWmsur1C.o /tmp/ffconf.eudlhu2d.c
    check_cflags -Werror=format-security
    test_cflags -Werror=format-security
    check_cc -Werror=format-security
    BEGIN /tmp/ffconf.eudlhu2d.c
    1 int x;
    END /tmp/ffconf.eudlhu2d.c
    gcc -D_ISOC99_SOURCE -D_FILE_OFFSET_BITS=64 -D_LARGEFILE_SOURCE -D_DEFAULT_SOURCE -std=c99 -maltivec -mabi=altivec -g -Wdeclaration-after-statement -Wall -Wdisabled-optimization -Wpointer-arith -Wredundant-decls -Wwrite-strings -Wtype-limits -Wundef -Wmissing-prototypes -Wstrict-prototypes -Wno-parentheses -Wno-switch -Wno-format-zero-length -Wno-pointer-sign -fno-math-errno -fno-signed-zeros -fno-tree-vectorize -Werror=implicit-function-declaration -Werror=missing-prototypes -Werror=return-type -Werror=declaration-after-statement -Werror=vla -Werror=format-security -c -o /tmp/ffconf.oWmsur1C.o /tmp/ffconf.eudlhu2d.c


    The result is not repetitive. Each executing of configure, generates configure.log finished on other progress.

    I have tried various options (e.g. --disable-pthreads, --disable-network), several versions of sources (fmpeg 1.2.12, 2.7.7, 3.3.3, libav 12.1).

    I have already built with success the sources of ffmpeg and libav on macOS Sierra.

    Has someone tried to build ffmpeg or libav for MorphOS? Does some have any idea how I can try?

    [ Edited by MDW 19.08.2017 - 18:09 ]
  • »19.08.17 - 10:49
    Profile Visit Website