• Priest of the Order of the Butterfly
    Priest of the Order of the Butterfly
    Posts: 874 from 2007/4/9
    From: Kingston upon ...
    Hi Noob,

    Boot into MorphOS and go to USB settings (right click on desktop, Settings>System choose 'USB' in the preferences panel).
    In USB preferences choose 'classes' in the left hand pane.

    There should now be a list of USB classes available, with some buttons below.
    In the 'class library' field (above the buttons) enter MOSSYS:Classes/USB/ (if it isn't already present).
    Press the 'Dir scan' button.*

    In USB preferences choose 'devices' in the left hand pane.
    Plug in your USB ethernet dongle. It should now show up in 'Devices' and automatically bind to the correct class (Pegasus.class in this case).**

    Press 'Save' to exit the USB prefs and return to the main prefs panel.

    Now go to the Network settings. Assuming all went well, your USB ethernet dongle should now be available as 'Eth1', and can be configured in the same way outlined earlier in the thread.

    Please let us know how it goes.


    * (This is the only time you should have to do this - all classes will be available from now on. I'm not sure why all classes aren't available by default to be honest).
    ** (although If you've forced a binding to a different class, this will need releasing before it will automatically bind to Pegasus.class.)

    [ Edited by boot_wb 10.11.2012 - 16:44 ]

    UI: Powerbook 5,6 (1.67GHz, 128MB VRam): OS3.1, OSX 10.5.8
    HTPC: Mac Mini G4 (1,5GHz, 64MB VRam): OS3.1 (ZVNC)
    Audiophile: Efika 5200b (SB Audigy): OS3.1 (VNC + Virtual Monitor)

    Windows free since 2011!
  • »10.11.12 - 14:15
    Profile Visit Website