• Butterfly
    Posts: 97 from 2005/10/31
    Interesting, but on the screenshot in the first thread it's radeon PCI, not PCIe one ? While card on screenshot do have Pex8112 onboard, it still physically PCI card, while in my case i tried to use PCIe X1950 over real bridge.

    Maybe in case with this exactly screenshot some changes in the kernel were done exactly to support this PCI card, to bypass OF which may configure it wrong or something ?

    For sake of tests i tried 2 bridges : the one based on Pex8112, and another one from Startech.com based on Pericom PI7CX9111SLBFDE : result for both the same:


    Radeon: Don't know how to initialise the memory controller of this Radeon
    Radeon: Memory size adjusted to 256MB

    If i wait a bit more while morphos's kernel trying to load up things, I got also those errors:


    Radeon: Failed to initialise Radeon DMA
    Radeon: Failed to allocate CCE DMA memory

    It's like Morphos's kernel can't find an address of the video memory when the card behind real physical bridge.
  • »17.09.23 - 12:05